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Habitat Monitoring Digitizing Guide 
Molly Foley: 09/2022 

Updated by Jared Elmore: 06/2024 
 

This guide contains information on how to digitize polygons for habitat monitoring. The first section is very detailed and 
is for ArcMap. This guide was put together by Molley Foley. A translation for ArcGIS Pro and QGIS have been created by 
Jared Elmore. The steps in ArcGIS Pro will be very similar to ArcMap, but are not fully fleshed out. The steps for QGIS 
have been created so that people without access to ESRI products may still be able to digitize data. The steps for QGIS 
have been fully tested when translating this guide. 
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Template Guidelines apply to all programs used 
• Do not add any new fields to the templates. 
• Do not alter the existing fields of the templates in any way (do not rename them, do not change the data types, 

do not change the domains, etc.) 
• Do not reproject or transform the coordinate system of the templates. 
• Each patch polygon you digitize MUST have values in these fields filled in: StateID, Point, PatchNum, 

IsDeveloped, CropTypeID, CnpyOver12, CnpyDecid, CnpyConif, ShrubCover, ObsvType, and ObsvDate. They 
cannot be null. See tables for descriptions of these fields. 

• If an observer does not enter 0 but leaves a field blank for any of these fields: ShbHiStemsDens, GrassCover, 
ForbCover, FrbAsProtect, ForbSpecies, BareGround, HerbHeight, or IsQuailHab, leave the field value <Null>. 

• You should be digitizing two separate layers: one with all survey point patch polygons and one with all 
protective cover polygons. Do not change the names of the template feature classes. 

o <StateID>_Patch_Template is where all patches that make up a survey point should be digitized 
o <StateID>_PC_Template is where all protective cover polygons should be digitized 

• The final dataset should not contain any gaps between polygons; polygons must have coincident boundaries. 
The program can only fix these errors within the tolerance of 1 meter. Zoom in and review all your points to 
ensure there are no gaps. 
 
Gap that needs removal    After removal 

 
 

• Patch polygons should not overlap each other. Boundaries of patches must be discreet. 
• The protective cover layer should sit on top of your patch polygons (think of it as layers of a cake). There should 

not be holes in the patches layer where your protective cover sits. There should not be any holes in the patches 
layer at all. 

• The script is designed to handle slivers but it is encouraged that you review your points to remove any slivers 
created during the digitizing process. 

• Do not submit data that has been submitted in a prior year! Submit only one year of data at a time. Export a 
subset of the data that you would like to submit for the current year and rename the datasets to 
<StateID>_Patch_Template and <StateID>_PC_Template before compressing the geodatabase and submitting. 

• For states with more than one focal area, it is perfectly ok to digitize and submit all areas in one template. You 
only need to split data into more templates if you have more than one year of data to be submitted. 

• If you choose to digitize your data outside of the template, be sure the field data types in your dataset match 
the field data types in the template. See tables for details on field data types in the template. Also see 
“Loading Data into the Template" section. 
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Quick Tips for Digitizing 
• Use the snapping toolbar!!! This will GREATLY reduce the amount of gaps and slivers you create in the digitizing 

process. 
• Zoom-in a lot and pan around your points to ensure that gaps and slivers are not present in your final dataset. 

They can be very hard to see if you do not zoom in very close.  
• Check that your patches meet the minimum mapping unit area (MMU) of 900 square meters. 

o  If it does not meet the MMU and is not a patch on the edge of your survey point, absorb the patch into 
a bordering patch (see the Eliminate tool in ArcMap).  

o If it does not meet the MMU but is a patch located on the edge of your survey point, check if the patch 
extends beyond the boundary of the survey point, allowing it to meet the MMU based on the area that 
falls outside the survey point (see page 8 of the habitat manual for an example). If it continues outside 
the survey point and it meets the MMU through this added area, you may leave it as is. If it does not, 
absorb the patch into a bordering patch (see the Eliminate tool in ArcMap). 

• Check that your protective cover meets the minimum mapping unit area of 314 square feet. If they do not, 
delete the polygon from the layer.

https://www.quailcount.org/monitoring/documents/CIP%20Habitat%20Monitoring%20Manual.pdf
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IN ARCMAP 

Adding Data to the Map 
This section covers the basics of ArcMap such as connecting to a folder, adding data to the map, and adding a basemap 
layer. 

1) Open ArcMap. Open the Catalog with this button near the top of your screen 
2) With the catalog pane now open on the right-hand side of your screen, click on the “Connect to Folder” button

 
3) Navigate to the folder where you have saved the unzipped habitat file geodatabase and click “Ok”. In the catalog 

pane you will now see the folder under the “Folder Connections” section: 

 

 

4) Highlight “<State>_Patch_Template” and drag it into the middle of the map. Do the same with the 
“<State>_PC_Template” layer. 

5) Next, add your aerial imagery, either following the same process as above to find your own aerial photos on 
your computer, or use the ESRI provided basemap imagery. To use an ESRI basemap, click the small black arrow 
next to the Add Data button:  

6) Click “Add Basemap…” and in the dialog that appears, click “Imagery” or “Imagery with Labels.” Your map may 
take a while to load the basemap, this is normal. 

7) Lastly, symbolize your Patch Template layer so you can see the basemap underneath. In the Table of Contents 
on the left side of the screen, click the colored box underneath the layer you would like to symbolize. 

 

 

 

 

 

 

8) In the new window that appears, set the Fill Color to “None”, the outline width to 1 or 2, and the outline color to 
something you can easily see (red or yellow usually works). Now you should be ready to start digitizing. 
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Digitizing Your Data  
This section covers how to digitize your data into the template.  

1. Add the Editor toolbar to the user interface. On the top menu bar, go to Customize > Toolbars > Editor 
2. Add the Snapping toolbar to the user interface. On the top menu bar, go to Customize > Toolbars > Snapping. 

Turn “Edge Snapping” on. 

 
3. If you have not already done so, add the two template layers, <StateID>_Patch_Template and 

<StateID>_PC_Template to the map. 
4. The templates come with pre-loaded 250-meter buffers that represent your monitoring points. Zoom to the 

point you wish to begin digitizing patches for.  
5. Before you begin editing, open the attribute table. Write down the value in the “SHAPE_Area” field. This will be 

important to check your work when you are done digitizing the whole point. 

 
6. Once you have a good view of your point, on the Editor toolbar click Editor > Start Editing 
7. On the Editor toolbar, click on the black mouse pointer (there are two of them on the ArcMap interface, be sure 

to select the one on the Editor toolbar). With that as your pointer, click on the buffer you wish to digitize 
patches for. 

 
8. With the point selected (you should see a bright blue outline on the buffer), on the Editor toolbar, click on the 

“Cut Polygons” tool. Begin outlining your first patch. Work from the edges of the circle inward. Double-click to 
complete your outline. A new feature should be created. If you receive an error message, please see the 
“Troubleshooting” section of this guide. 

 
9. Open the attribute table of the layer, you will notice that there are two features selected. Only one of these 

records is the new patch you digitized. To figure out which is which, you may click the small gray area next to the 
row to highlight the feature in yellow on the map. Type data into the fields for the patch you’ve created. You 
may also digitize all your points and do this at the end if you find that more efficient. 
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10.  When you have completed digitizing all patches on the point, open the attribute table and select all the features 
that make up the single point. You may do this easily by going to the top menu bar > Selection > Select by 
Attributes. Enter this expression (with all quotation marks included): Point = ‘<enter the point name of the 
digitized point here>’. 

 
 

11. With all features that make up the point selected, in the attribute table, right-click the “SHAPE_Area” header > 
Statistics. Look at the “Sum” value. Ensure that it closely resembles the value you wrote down in step 6, it may 
be decimals off. 

12. If there is a portion of the point that you did not collect data for (ex: its private land you do not have permission 
to access), be sure to delete left over polygon(s) when you have completed digitizing the point. First, clear any 
selection you may have by clicking the “Clear Selection” button near the top of your screen (your button layout 
may look different than below). 
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13. With the black mouse pointer on the Editor toolbar, click the polygon you wish to delete. Open the attribute 

table and after ensuring the appropriate features are selected, click the X to delete the feature(s). 

 

14. Repeat steps 5-14 for all points.  
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Loading Data into the Template 
This section covers how to load your data into the template from another shapefile or geodatabase if you did 
not choose to digitize your patches directly into the template.  

1. Open ArcMap and add the Editor toolbar to the user interface. On the top menu bar, go to Customize > Toolbars 
> Editor 

2. Add the “Load Objects” command to the Editor toolbar.  
a. On the top menu bar, go to Customize > Customize Mode… > Commands tab > Type “Load Objects” into 

the search bar.  

 

b. Under the “Commands” side of the dialogue box, click and drag the “Load Objects” command to the 
Editor toolbar and drop it. The Editor toolbar will now look something like this (the order of the buttons 
doesn’t matter): 

 
3. Add the dataset that contains your digitized patch data to the map. If it contains habitat data you have already 

submitted in previous years, select the data you would like to submit for the current year and export it to a new 
file. Please do not submit data that has already been submitted in prior years! 

a. You can use the “Select by Attributes” tool to select a subset of data in your dataset. 
b. After selecting the subset, right-click the layer name in the table of contents > Data > Export Data... and 

leave Export set to “Selected Features”, use the same coordinate system as the layer’s source data, and 
save the output feature class where you can access it. You may choose whether to save it as a feature 
class (which must be saved inside a geodatabase) or as a shapefile. 

c. Add the exported data to the map when prompted. 
4. Add both <StateID>_Patch_Template and <StateID>_PC_Template layers to the map 

http://desktop.arcgis.com/en/arcmap/latest/map/working-with-layers/using-select-by-attributes.htm
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5. Open the <StateID>_Patch_Template attribute table. In the Table of Contents (typically left side of screen), right-
click the layer and click “Open Attribute Table.” 

6. On the Editor toolbar, click Editor > Start Editing. In the dialogue that opens, click on <StateID>_Patch_Template. 
7. Click the “Table Options” button > Select All > click the X to delete all the records. This will delete the pre-loaded 

250 meter buffers. Since you have already digitized your dataset, we do not want to submit these buffers with it. 
Iowa may skip this step. 

 
8. On the Editor toolbar, click “Load Objects” 
9. In the dialogue that opens, click the browse folder button and navigate to your digitized patch dataset or the 

exported patch dataset you created in step 3 if applicable. Click “Open” when you have chosen the correct file, 
then click “Add” 
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10. Click “Next” 
11. Ensure the target dataset is set to <StateID>_Patch_Template. 
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12. Click “Next” 
13. Match fields from the target dataset up with the fields in your digitized dataset (“Matching Source Field”). If the 

field data type (string, int, float, etc.) does not match the target dataset’s field data type, the tool will run but 
the column or rows may not populate with values as you would expect. You must then fix the rows in your 
digitized dataset so they match the target dataset and run the tool again. The names of the fields do not need to 
match but the field data types do. 
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14. Click “Next” 
15. On the next dialogue, click “Load all of the source data” and click “Next” 
16. Click “No” on the input features being snapped. Click “Yes” to validate the new features. Click “Next” 
17. Review the information and click “Finish” 
18. Right-click the <StateID>_Patch_Template in your table of contents and open the attribute table. Review the 

features to determine that all have loaded successfully. If any of them are highlighted in blue, they did not pass 
validation and something went wrong during data transfer. 

a. Change the view on the attribute table to only show selected records; at the bottom of the attribute 
table, there are two buttons, click the one on the right that is completely blue. 

 
b. This view contains all the features that were marked invalid. Select a single record by clicking the gray 

box to the left of the row. 

 
c. With that record selected, go the Editor Toolbar, click Editor > Validate Features 
d. The message that appears will give you some information about why the feature is invalid. You may 

repeat this on the other invalid features to determine if the error is the same for all them. 
e. Fix what is causing the issue in your digitized dataset.  
f. Delete the features in the template dataset. Switch back the view to display all records (click the left 

button seen in step 18a). Click the Table Options button > Select All. All records will be highlighted in 
blue. Click the “X” on the table toolbar to delete them.  

 
g. Repeat steps 5, 6, and 8 - 18 to try loading the features again. 

19. Repeat this process with your digitized protective cover, ensuring you are choosing the appropriate protective 
cover layers for steps 9 and 11 (and 3 if applicable).  

20. When you have loaded features into both the Patches_Template and the PC_Template and they have been 
validated, save your edits and stop editing. On the Editor toolbar, go to Editor > Stop Editing. Save the edits 
when prompted. 
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Submitting Your Data 
Using the NBCI Habitat Monitoring and Management Data Explorer, you can submit your data in the form of a zipped file 
geodatabase.  

1. Check that your data is structured appropriately before compressing the file geodatabase. Your file geodatabase 
should contain only two layers: <StateID>_Patch_Template and <StateID>_PC_Template. They must be named 
in this exact format. In ArcCatalog, it should look something like this: 

 
 

2. Compress the geodatabase using Windows File Explorer. Be sure to compress the folder that ends in the 
extension .gdb. Do not submit zip files where the .gdb folder is nested inside another folder. Do not create a 
new folder called State_Habitat.gdb and place the State_Habitat.gdb file geodatabase inside and zip the 
containing one. Zip the only one that is visible in windows file explorer (it already exists). 

 Compress this 
After it has been zipped, it should look like this: 

 Notice it ends in .gdb.zip 
 

3. Open the Data Explorer. Click the classification icon on the right side of the map: 

 
 

4. In the dialogue that opens, choose your state and add your zipped geodatabase. Click “Classify Habitat” 

 
 

5. Results should be viewable in ten minutes. You will receive an email from nbciquailcount@gmail.com when your 
data has finished processing (or encountered an error). 

mailto:nbciquailcount@gmail.com
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<StateID>_Patch_Template Attribute Table Fields 
Field Name Field Data Type Description Example Value(s) 

StateID Text; does not 
allow nulls 

The two letter abbreviation of your state. When you create a new feature in the 
template, it will default to your StateID.  

KY 

Point Text; does not 
allow nulls 

A dropdown list where you can pick the name and/or number of the survey point the 
feature is located on. This field is specific to your state, please see last page for your 
state’s point naming schema (this was the schema you designed when your state 
submitted your monitoring points to us). Corresponds to “Point ID” cell on datasheet. 

RA20; 
OH-ICRA-16; 
M_41;  
1;  

PatchNum Long; does not 
allow nulls 

Each survey point contains multiple patches, each patch has a number. This 
corresponds to the “Patch Number” cell on the paper datasheet. 

6 

IsDeveloped Long; does not 
allow nulls 

Corresponds to “Is this developed land or non-habitat?” on paper datasheet. Appears 
as dropdown list in template; if digitizing outside of template, use 1 for Yes and 0 for 
No. 

Patch is developed or 
non-habitat; 
Patch is not developed 
or non-habitat 

CropTypeID Long; does not 
allow nulls 

Corresponds to “Crop Type” on paper datasheet. Appears as dropdown list in 
template; if digitizing outside of template, use integer values below appropriately: 
0 – None 
1 – Corn 
2 – Potato 
3 – Soybean 
4 – Wheat  
5 – Grain sorghum 
6 – Sweet Potato 
7 – Tobacco 
8 – Barley 
9 – Cotton 
10 – Oats 
11 – Flax 
12 – Rye  
13 – Cereal 
14 – Peanuts 
15 – Tomato 
16 – Cabbage 

Corn 
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17 – Sugarcane 
18 – Watermelon 
19 – Pumpkin 
20 – Sugar beets 
21 – Other  

CropResidue Float Corresponds to “What % of field has standing crop residue in spring?” 20 
CnpyOver12 Float; does not 

allow nulls 
Corresponds to “What is the % canopy of vegetation >12 ft tall?” 15 

CnpyDecid Float; does not 
allow nulls 

Corresponds to “What % of the canopy are deciduous trees?” 75 

CnpyConif Float; does not 
allow nulls 

Corresponds to “What % of the canopy are coniferous trees?” 25 

ShrubCover Float; does not 
allow nulls 

Corresponds to “What is the % of the shrub cover in the understory?” 5 

ShbHiStemsDens Float Corresponds to “What % of the shrub cover has high stem densities near the 
ground?” 

5 

GrassCover Float Corresponds to “What is the % grass cover in the understory?” 25 
ForbCover Float Corresponds to “What is the % forb cover in the understory?” 35 
FrbAsProtect Float Corresponds to “What % of the forb cover can act as protective cover?” 20 
ForbSpecies Long Corresponds to “How many forb species are present?” 3 
BareGround Float Corresponds to “What is the % bare ground, including underneath vegetation?” 50 
HerbHeight Long Corresponds to “Is the herbaceous vegetation height >8 in for >50% of the year?” 

Appears as dropdown list in template; if digitizing outside of template, use 1 for Yes 
and 0 for No. 

Yes; 
No 

IsQuailHab Long Corresponds to “Do you think this patch is quail habitat?” Appears as dropdown list 
in template; if digitizing outside of template, use 1 for Yes and 0 for No. 

Yes; 
No 

ObsvType Long; does not 
allow nulls 

Did you walk the entire patch, estimate from the road, interpret from a photo, or use 
some other method to gather structural data? The default value is Walked. Appears 
as dropdown list in template; if digitizing outside of template, use integer values 
below appropriately.  
1 – Walked 
2 – Road observation 
3 – Photo interpretation 
4 – Other  

Walked 
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ObsvDate Date; does not 
allow nulls 

Corresponds to “Date” cell on paper datasheet. Format as MM/DD/YYYY (ArcMap 
changes 01/01/2015 to 1/1/2015, that’s ok).  

1/1/2018; 
12/15/2016 

FirstName Text Corresponds to “Observer” cell on paper datasheet; only put their first name in this 
field. 

Molly 

LastName Text Corresponds to “Observer” cell on paper datasheet; only put their last name in this 
field. 

Foley 

Comments Text Any comments you wish to add about a particular patch Saw a bobwhite here. 
 

<StateID>_PC_Template Attribute Table Fields 
Field Name Field Data Type Description Example Value(s) 

StateID Text; does not 
allow nulls 

The two letter abbreviation of your state. When you create a new feature in the 
template, it will default to your StateID. 

KY 

Type Long; does not 
allow nulls 

Identifies the protective cover as either herbaceous or woody type. The default value 
is Woody. Appears as dropdown list in template; if digitizing outside of template, use 
1 for Herbaceous and 2 for Woody 

Herbaceous; 
Woody 

Comments Text Any comments you wish to add about a particular protective cover patch Lots of blackberry. 
 

State Survey Point Naming Schemas 
State Focal Area Point Names Reference Area Point Names 

Alabama QP1 through QP5, QP6R8, QP7 through 
QP12, QP13R8, QP14 through QP20, QP21R8 
through QP24R8 

RAQP1 through RAQP20, RAQP21R8, RAQP22 
through RAQP24 

Arkansas AR_PR_01 through AR_PR_12 N/A 
Delaware F1 through F14 R1 through R14 
Georgia (for West SL) SL1, SL14, SL22, SL38 through 

SL40, SL43, SL45 through SL51 
(for Chickasawhatchee) C1 through C48 

MC1 through MC21 

Illinois BA_FA00 through BA_FA24 BA_RA00 through BA_RA20 
Iowa (for Ringgold) 1 through 44;  

(for Shawtee) 3601 through 3630 
101 through 134 
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Kentucky (for Livingston) F1 through F24 
(for Peabody) P2, P4 through P6, P8 through 
P15, P17, and P18. 
(for Wendell Ford) W3 through W15 

C1 through C24 

Louisiana FA1 through FA25 RA1 through RA25 
Mississippi F1 through F15 R1 through R15 
Missouri 25 through 48; 

BR6, BR7, BR8, BR14, BR15, BR19 and BR64 
through BR80 

1 through 24; 
BR41 through BR63 

Nebraska M_1 through M_60 R_1 through R_60 
New Jersey F1 through F25 R1 through R25 
Ohio OH-FQHA-0 through OH-FQHA-41 OH-ICRA-0 through OH-ICRA-41 
Oklahoma C-FA00 through C-FA19 A-RA00 through A-RA10; 

J-RA00 through J-RA07 
Pennsylvania L1 through L15; 

M1 through M10 
N/A 

South Carolina F1 through F12 R1 through R12 
Tennessee WR1 through WR13 MA1 through MA13 
Texas SEFOCUSAREA01 through SEFOCUSAREA40 SEREFERENCEAREA01 through 

SEREFERENCEAREA43 
Virginia (for Sussex) BP1 through BP31 

(for Manassas) MB01 through MB09, MB11 
MB13, MB14, MB16, MB19, MB20, MB22, 
MB25, MB28, MB30 

(for Sussex) SR0 through SR30 
(for Manassas) SB01, SB03 through SB08, 
SB10, SB12, SB13, SB15 through SB21, SB23, 
SB24 
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Troubleshooting 
Sometimes when you are digitizing you will receive this error message: 

 

 

This error occurs because the polygon you are cutting out is not completely surrounded by edges of 
another selected polygon (“container polygon”). For example: 

This will result in the error. You can see that the upside-down U-shaped polygon is selected and I am 
trying to cut out a polygon that does not lie inside its blue-colored lines. 
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This will cut the polygons as intended. You can see the blue-colored lines of the polygon that is selected 
completely contains the polygon I am attempting to cut out.  

 

 

If you receive this error because you have the wrong polygon selected, click the black cursor on the 
Editor toolbar and use it to click the intended container polygon. Then use the Cut Polygons tool to 
attempt to draw your new polygon again. 

 The Edit cursor looks like this:  
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THE FOLLOWING ARE TRANSLATIONS FOR DIGITIZATION IN ARCGIS PRO AND QGIS.  

IN ARCGIS PRO 
 

### ArcGIS Pro Digitizing Guide 

 

#### 1. Template Guidelines 

- **Do not add any new fields to the templates.** 

- **Do not alter the existing fields of the templates in any way (do not rename them, do not change the 
data types, do not change the domains, etc.).** 

- **Do not reproject or transform the coordinate system of the templates.** 

- **Ensure mandatory fields are filled:** Each patch polygon you digitize must have values in these 
fields filled in: StateID, Point, PatchNum, IsDeveloped, CropTypeID, CnpyOver12, CnpyDecid, CnpyConif, 
ShrubCover, ObsvType, and ObsvDate. 

- **Handling null fields:** Leave fields blank for values such as ShbHiStemsDens, GrassCover, ForbCover, 
FrbAsProtect, ForbSpecies, BareGround, HerbHeight, or IsQuailHab if not observed. 

- **Digitize two separate layers:** One with all survey point patch polygons and one with all protective 
cover polygons, ensuring no gaps or overlaps between polygons. 

 

#### 2. Quick Tips for Digitizing 

- **Use Snapping:** Enable snapping to reduce gaps and slivers. 

- **Zoom in:** Frequently zoom in and pan around your points to ensure accuracy. 

- **Check minimum mapping units (MMU):** Ensure patches and protective covers meet their 
respective MMU requirements. 

 

#### 3. Adding Data to the Map 

1. **Open ArcGIS Pro and create a new project.** 

2. **Add the template layers to the map:** 

   - Go to the `Map` tab and select `Add Data`. 

   - Browse to your `<StateID>_Patch_Template` and `<StateID>_PC_Template` files and add them to the 
map. 

3. **Add basemap imagery:** 
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   - Go to the `Map` tab and select `Basemap`. 

   - Choose an appropriate basemap from the dropdown list. 

4. **Symbolize your Patch Template layer:** 

   - Right-click the layer in the Contents pane, select `Symbology`. 

   - In the `Symbology` pane, set the fill to `No Color` and choose a visible outline color. 

 

#### 4. Digitizing Your Data 

1. **Add the Editing toolbar:** 

   - Go to the `Edit` tab to access the editing tools. 

2. **Enable Snapping:** 

   - In the `Edit` tab, select `Snapping`. 

   - Ensure `Snapping` is turned on and set snapping type to `Vertex` and `Edge`. 

3. **Start Editing:** 

   - Select your `<StateID>_Patch_Template` layer, right-click, and select `Enable Editing`. 

   - Use the `Create` tool from the `Edit` tab to start digitizing patches. 

4. **Attribute Table:** 

   - Right-click the layer, select `Attribute Table`. 

   - Manually enter the required data for each polygon. 

5. **Check SHAPE_Area:** 

   - After digitizing, use the `Calculate Geometry` tool in the attribute table to calculate and compare the 
area. 

 

#### 5. Loading Data into the Template 

1. **If digitizing outside of the template:** 

   - Ensure your fields match the required template field types. 

   - Use `Analysis` > `Tools` > `Join` > `Spatial Join` to integrate data into the template. 

 

#### 6. Submitting Your Data 

1. **Check your data structure:** 
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   - Ensure your geodatabase contains only the `<StateID>_Patch_Template` and 
`<StateID>_PC_Template` layers. 

2. **Compress the geodatabase:** 

   - Use your operating system’s file compression tool to create a `.zip` file of the geodatabase. 

3. **Upload and submit:** 

   - Follow the specified procedure in your monitoring guide to upload the zipped geodatabase. 
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IN QGIS 
 

QGIS Digitizing Guide 

QGIS may also be used for digitization. It is open source and free to download, so that 
digitization may be conducted without the use of ESRI products. Please download the most 
recent version of QGIS at: https://www.qgis.org/en/site/  

- Please read all information and instructions. 
1.  Adding Data to the Map 

a. Open QGIS and create a new project by clicking the icon on the top left that looks 

like a page with the corner folded over.  
b. Add the template layers to the map: 
c. Go to `Layer > Add Layer > Add Vector Layer`. In the box that pops up, select 

directory, change the source type to OpenFileGDB, and select the geodatabase 
that you downloaded from quailcount. Click Add. 

 
d. Select both `<StateID>_Patch_Template` and `<StateID>_PC_Template` layers 

and click add again. Then click the top coordinate system.  
2. Add basemap imagery: 

https://www.qgis.org/en/site/
https://mapscaping.com/working-with-esri-file-geodatabase-gdb-files-in-qgis-and-gdal/
https://opengislab.com/blog/2018/4/15/add-basemaps-in-qgis-30
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a. Go to the plugins tool and install the QuickMapServices plugin. Then click 
QuickMapServices Settings button, go to ‘more services’, and click Get 
Contributed Pack button. 

b. Click `Web > QuickMapServices > OSM > ‘Google Hybrid’ (or other appropriate 
basemap). 

3. Symbolize your Patch Template layer. 
a. Right-click the layer in the Layers panel, select `Properties`. 
b. In the `Symbology` tab, set the fill style to `No Brush` and choose a visible 

outline color. 
4. Digitizing Your Data 

a. Add the Editor toolbar. 
b. QGIS has an integrated editing toolbar. Right-click on the toolbar area and ensure 

the `Digitizing` toolbar is enabled. 

 
5. Enable Snapping: 

a. Go to `Project > Snapping Options`. Click the magnet on the left to enable 
snapping. 

b. Set snapping type to `Vertex and Segment` and tolerance as required. 

 
6. Reduce opacity of selection color. Click Project, Properties, General, selection color, and 

reduce opacity to ~10%. 
7. Start Editing: 

a. Select your `<StateID>_Patch_Template` layer, right-click, and select `Toggle 
Editing`. 

b. Select the feature that you want to edit using the select feature tool.  
c. Click the ‘Edit’ tab, go to edit geometry, and click the split features tool. Click on 

the edge of the polygon (which should snap since you already enabled snapping), 
and digitize the polygon, right clicking on the final point at the next boundary to 
finish the split. 
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d. Continue splitting features by first selecting the polygon, then using the split 
features tool. Your final result should look something like this: 

 
8. Attribute Table: 

a. Right-click the layer, select `Open Attribute Table`. 
b. Manually enter the required data for each polygon. 
c. Ensure that you’re entering the correct data for each polygon of interest from your 

field data. 
d. save your edits. Save your project 

9. Editing the `<StateID>_PC_Template` layer. 
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a. In this layer, you are simply adding polygons for protective cover. Select your 
`<StateID>_Patch_Template` layer, right-click, and select `Toggle Editing`. Use 

the add polygon tool to digitize the protective cover polygons.  
b. Follow step 5 above to edit the attribute table. 

10. Submitting Your Data 
a. Check your data structure: Ensure your geodatabase contains only the 

`<StateID>_Patch_Template` and/or `<StateID>_PC_Template` layers. 
b. Compress the geodatabase by using your operating system’s file compression tool 

to create a `.zip` file of the geodatabase. 
11. Upload and submit: 

a. Follow the specified procedure in your monitoring guide to upload the zipped 
geodatabase. Or, email to the NBGI science coordinator. 
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